Web Ratio Add-ons shop not working

15 May '15, 12:57 PM
No Forum Badges

Hello everybody!

I can not access Web Ratio Add-ons, everytime I click on Web Ratio Addons in the app I am getting this error:

Exception in thread "Thread-13" org.jvnet.mimepull.MIMEParsingException: java.io.IOException: chunked stream ended unexpectedly
    at org.jvnet.mimepull.MIMEParser.fillBuf(MIMEParser.java:441)
    at org.jvnet.mimepull.MIMEParser.readBody(MIMEParser.java:209)
    at org.jvnet.mimepull.MIMEParser.access$600(MIMEParser.java:67)
    at org.jvnet.mimepull.MIMEParser$MIMEEventIterator.next(MIMEParser.java:159)
    at org.jvnet.mimepull.MIMEParser$MIMEEventIterator.next(MIMEParser.java:128)
    at org.jvnet.mimepull.MIMEMessage.makeProgress(MIMEMessage.java:198)
    at org.jvnet.mimepull.MIMEMessage.parseAll(MIMEMessage.java:181)
    at org.jvnet.mimepull.MIMEMessage.getAttachments(MIMEMessage.java:106)
    at com.webratio.base.http.MultipartParser.parse(MultipartParser.java:50)
    at com.webratio.base.http.MultipartParser.parse(MultipartParser.java:44)
    at com.webratio.base.http.HttpResponse.parse(HttpResponse.java:109)
    at com.webratio.base.http.HttpResponse.getMessage(HttpResponse.java:86)
    at com.webratio.ide.store.core.StoreClient.getItems(StoreClient.java:116)
    at com.webratio.ide.store.core.StoreModel$LoadStoresThread.doRun(StoreModel.java:162)
    at com.webratio.ide.store.core.StoreModel$LoadStoresThread.run(StoreModel.java:153)
Caused by: java.io.IOException: chunked stream ended unexpectedly
    at org.apache.commons.httpclient.ChunkedInputStream.getChunkSizeFromInputStream(ChunkedInputStream.java:252)
    at org.apache.commons.httpclient.ChunkedInputStream.nextChunk(ChunkedInputStream.java:221)
    at org.apache.commons.httpclient.ChunkedInputStream.read(ChunkedInputStream.java:176)
    at java.io.FilterInputStream.read(FilterInputStream.java:133)
    at org.apache.commons.httpclient.AutoCloseInputStream.read(AutoCloseInputStream.java:108)
    at org.jvnet.mimepull.MIMEParser.fillBuf(MIMEParser.java:439)
    ... 14 more


and addons list is not loading.

Windows 7, Java version is 1.7, so that is ok:

"C:\WebRatio\WebRatio Platform 7.2.7.x64bit\WebRatio\WebRatio.exe" -vm "C:\Program Files\Java\jdk1.7.0_79\bin\javaw.exe"

WebRatio Platform
Version: 7.2.7
Build id: 201410240114

x 0
Answer Answer at this question and get points!
Forum Expert - Level 5

Hi Amir,

We tried to download the Twitter component from the WebRatio Add-ons but it seems to work correctly. You can to connect to another internet network to try to download the component? It may be that your University has set other restrictions on the free network and therefore it is not a problem linked to your PC but the entire university network that for security reasons close some doors.

Let us know if now you can download the component.

Best regards,

Ombretta Malinverno

x 1
No Forum Badges

Hi, Ombretta!

I tried to connect the addons store from my home network, result was the same - error with chunked stream

Best regards,


x 0
Answer at this question and get points!

Related questions

404 on generated app page 500 error with WebRatio BPM 502 proxy error-generate and run Add to Bag link in ACME Admin area disabled aggiornamento fallito a causa di un errore interno Ajax and FCK Editor (WebRatio 5.x) AJAX events problem to external JavaScript Ajax onchange and jQuery 2.x (with migrate plugin) incompatible Any sample deployment Any way to localize the Tab Grid Template (Webratio Store)? Can not get generate and run option for DataService Project Cannot invoke method putAll() on null object Cannot invoke method selectSingleNode() on null object Can't run any aplication Code is exceeding the 65535 bytes limit error on JBOSS Como se usa la componente paypal en web ratio? Compare with the current time Component computation Componente de pagos paypal com.webratio.struts.exceptions.WRSecurityException: Invalid request target host Connection refused. Could not open the editor: This copy of WebRatio is not registered Creación DB Apache Derby - Modelado BPMN CSV Component with utf8 encoding Database connection, Host and Port number DB in Data Service Project Debug configuration error activating student account Error deploying WAR against to JBOSS Error updating metadata process Error when updating to WR 7.2.3 Examples at WebRatio 7.2 (Acme, BookStore, ...) Examples of WebRatio (Acme) Facebook login and personalization Facebook Unit Filtros Caracteres Especiales Find Model Problemas Format currency From BPM to WebProject - BUILD FAILED Generation errors on ajax enabled page with many components, ajax links and selective refresh "Generation Error" with Generate and Run Geolocalizzazione con Twitter Component Google map is not shown properly in the tab grid Graph Component Problem Groovy script numer after an error HelloWorld Unit sample code Help with math unit. Debug mode says error as result code Hierarchy component How can I add a credit card payment gateway or integrate paypal in my web app logic? How can I see the administration page of bookstore example on the cloud? how to delete this error? How to get a wr:AjaxURL tag working How to modify the FertileEnviroment Default page How to scale a image? How to use GoogleGeocoding Add-on i can't install mobile version on windows I can't install Webratio on my Desktop (Ubuntu 13.04 x64) I can't run any application with WebRatio (Table/View 'APP.POST' does not exist) Installation with java 1.8 Installazione Macosx invio mail fallito java.lang.NullPointerException java virtual machine error Job not start correctly JSP/DO issues on Tomcat 5.5 (Ubuntu) Login Error mandatory control code parameter is missing Mensaje: the selection cannot be launched and there are no recent launches Missing plugin emulation support error Missing units when importing project Multi Selects didn't work in update page Next Activity Note property - Error synchronizing with web project No access to protected site view with Login No Apache Derby driver found No database on my cloud account Overlays for Google Map Unit. Page Home - First time the Project Web begins Problema al generar y ejecutar proyecto Problema generazione codice Problema Grafo da una lista gerarchica Problema ¨HTTP Status 404" Problemas con el Operations View Delete Problem: Compile Failed problemi installazione su Mac sistema operativo OSX El Capitan problem on first deploy with webratio Problems to connect Sql Server DB from Webratio Problems with the page refresh (Tab Grid) Problem syncing reports Problem to run an Application Problem with adding templates Problem with application runnung Problem with execution of webratio Problem with ireport Problem with the deletion of more than 50.000 records in a table Project cannot be opened with WebRatio Community Platform Sample web application Selezione sul giorno "Events Planning" Showing items that have a relation with an entity Solve "Generation Error" with Generate and Run option Statistics Component for WebRatio > 7.2.0 store problme Student reserved area, download error Table 'freeapp43.profesion' doesn't exist Target tabs in Tab Grid Control Tomcat external session store and WebRatio webapp. Twitter Unit - Get Geo location of twitt "Unable to close sub-context ..." Unable to compute the controller URL(s) for applicationUnable to compute the controller URL(s) for application having status PROVISIONING Unable to connect to Internet Unable to execute the script java.lang.NullPointerException Unable to find Cloud free function Unable to get ExpenseReport example work in WebRation Personl 7.2.2 Unable to instantiate a new application instance Unable to update the web project Unspecified BPM Engine Database Updating attributes of an entity Usage of the Gantt Unit User Login Timestamp Webratio - Add-ons Webratio Add-ons no permite login WEBRATIO LINUX AT EXECUTION TIME Web Ratio Mobile plateform Macos Sierra Web Ratio Mobile - Remote data mapping problem WebRation Store connection problem When execute my web application I have this error: returned a null bean When stars web ratio between dofollow and nofollow backlink has affected? Where can i find ifml sample with webratio? Where is the ACME demo data stored?! which of these three models is closer to webratio/ifml way of creating web applications XPCOM Error