WAR Generation Error

13 Jul '15, 10:15 AM
4,327 Views
Forum Forum Starter - Level 3

Hello,

I'm trying to create a WAR, It just working fine, now everytime I Try to generate I got this error.. 

 

[12 Jul 2015 21:41:02,614] org.eclipse.core.runtime.CoreException: /Applications/WebRatio 7.2.7/WebRatio/configuration/org.eclipse.osgi/bundles/49/1/.cp/Scripts/WAR.xml:20: The following error occurred while executing this line:

/Applications/WebRatio 7.2.7/WebRatio/configuration/org.eclipse.osgi/bundles/49/1/.cp/Scripts/WAR.xml:13: Deployment descriptor: /Applications/WebRatio 7.2.7/Tomcat/webapps/APPNAME/WEB-INF/web.xml does not exist.

    at org.eclipse.ant.core.AntRunner.handleInvocationTargetException(AntRunner.java:452)

    at org.eclipse.ant.core.AntRunner.run(AntRunner.java:384)

    at org.eclipse.ant.core.AntRunner.run(AntRunner.java:475)

    at com.webratio.ide.deploy.core.jobs.AbstractDeploymentJob.runAnt(AbstractDeploymentJob.java:207)

    at com.webratio.ide.deploy.core.jobs.AbstractDeploymentJob.runPluginAnt(AbstractDeploymentJob.java:180)

    at com.webratio.ide.deploy.core.jobs.WarCreatorJob.doRun(WarCreatorJob.java:90)

    at com.webratio.ide.deploy.core.jobs.AbstractDeploymentJob.runExternal(AbstractDeploymentJob.java:84)

    at com.webratio.commons.mf.jobs.ExternalJob.run(ExternalJob.java:53)

    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

Caused by: /Applications/WebRatio 7.2.7/WebRatio/configuration/org.eclipse.osgi/bundles/49/1/.cp/Scripts/WAR.xml:20: The following error occurred while executing this line:

/Applications/WebRatio 7.2.7/WebRatio/configuration/org.eclipse.osgi/bundles/49/1/.cp/Scripts/WAR.xml:13: Deployment descriptor: /Applications/WebRatio 7.2.7/Tomcat/webapps/APPNAME/WEB-INF/web.xml does not exist.

 

Does anybody has the same issue? Or anyone just fixed?

Thanks.

 
x 0
Follow
Answer Answer at this question and get points!
Forum Hero - Level 9

Hi,

   You should check your deploy configuration, for example if you use webservices you should check if the url or wsdl file exist otherwise you'll have these problem.

   
x 0
Forum Hero - Level 9

Hi,

the generated project seems to be incomplete: "/Applications/WebRatio 7.2.7/Tomcat/webapps/APPNAME/WEB-INF/web.xml does not exist".

In this case I suggest you to check the java version used to run WebRatio. WebRatio 7 does not support JDK 1.8. If it is the case you should use Oracle jdk 1.6 or 1.7.

 
x 0
Forum Starter - Level 3

Thanks Vero!

 
x 0
Answer at this question and get points!