Unsupported Java Developement Kit version 6 or 7 is required

05 Feb, 09:25 PM
3,974 Views

Hello everyone!

I was tring to install WebRatio in my computer, but during the installation, I got the following error:

"Unsupported Java Developement Kit version 6 or 7 is required "

The path is the next one:

_\Program Files\Java\jdk1.7.0_80

Someone knows what is happening?

Regards, Adrián. 

 
x 0
Follow
Answer Answer at this question and get points!
Forum Hero - Level 9

Hi,

If you are trying to install (or run) WebRatio 7, java 7 is required. If Java 7 is already installed it will be automatically identified by WebRatio installer wizard and you could change it if it is not the correct one.

Reported path (_\Program Files\Java\jdk1.7.0_80) it is wrong: I don't know if this is due to a manual typing but this is wrong. if jdk1.7.0_80 was installed the target path should be like C : \ Program Files \ Java \ jdk1.7.0_80 (ignore the blank spaces).

Moreover if the problem is reported when you start WebRatio, there are different versions of java (e.g. 7, 8 and higher) on your machine and you are running WebRatio from the exe file you have to edit the WebRatio.ini file to set the correct vm path.

  • Open WebRatio.ini file available in <WebRatio>\...\WebRatio\ folder
  • Append these rows before –vmargs
    ….
    -vm
    C:/Program Files/Java/jdk1.7.0_80/bin/javaw.exe

    -vmargs
    ….
  • Run WebRatio.exe

 
x 0
Answer at this question and get points!