"Generation Error" with Generate and Run

21 Nov '19, 11:35 AM
No Forum Badges


I've a problem.
When I click "Generate and Run" on the WebRatio Platform Community Edition the console generate the following error:

[21 Nov 2019 11:31:50,576] Generation Error

Do you know how I can resolve or get more details on the error?
I am already using JDK 7 and I also tried JDK 6.


x 0
Answer Answer at this question and get points!
Forum Hero - Level 9

Hi Fabrizio,

Your model could contain errors that prevent the correct generation.
In this case I suggest you to run the Find Model Problems and Find Layout Problems commands and solve the returned problems. To find these commands you have to select the “Project” node from the Outline View and choose "Find" item from the context menu.

Moreover if you double click on errors reported in the Generation Error View you can obtain more details about them.


x 0
Answer at this question and get points!

Related questions

404 on generated app page 500 error with WebRatio BPM 502 proxy error-generate and run Acceder a diferentes site views/ Acces to diferents site views A Commercial Hosting Service for the publication of a Website? Add logging capability to a Groovy script (unit) Add to Bag link in ACME Admin area disabled aggiornamento fallito a causa di un errore interno Ajax and FCK Editor (WebRatio 5.x) AJAX events problem to external JavaScript Ajax onchange and jQuery 2.x (with migrate plugin) incompatible Any sample deployment any webratio book ? application not deploying properly Asking For a Book Attribute comparison in a selector unit Automatization of deployment AWS Elastic Beanstalk y Webratio Build Project. Only files for compilation .class Can I deploy an application to the cloud using RightScale and/or Scalr? Can I integrate Amazon S3 and/or Amazon CloudFront? Can I use Git with Webratio Cannot invoke method putAll() on null object Cannot invoke method selectSingleNode() on null object Can't generate and run database or start tomcat server! Can't run any aplication Change uplod directory and protect anauthorized access to files Clarification about the NoOperation unit Code is exceeding the 65535 bytes limit error on JBOSS Codigo QR Como hacer un menu en webratio? Compare with the current time Component computation com.webratio.struts.exceptions.WRSecurityException: Invalid request target host Conditional Expression "greater than 0" on null fields Connection refused. Connect more query unit Content module page variable won't assign. coupled mandatory fields Create Unit with Date (Year only) Custom Attributes Condition Database Database connection, Host and Port number Database List is not showing up in App Emulator Data flow from a page which is not visible anymore Data is always created doubled Data Management: Updating Data - Attachments - Updating Data Sample Project Final DB in Data Service Project Debug configuration Deploy de proyecto en HTTPS Deploying to CloudBees Deploy web project da riga di comando Description: Unknown tag 'wr:LinkResource' Doanload previous version on webratio Dudas sobre modelado(Data Flow,Forms y Operation Create) Empty record mistakenly saved en_US codify problem error activating student account Error deploying Bookstore sample to cloud Error deploying WAR against to JBOSS Error testing mobil app in android Error updating metadata process Error when updating to WR 7.2.3 Export XML external link.= Filter information in a Simple List Filtros Caracteres Especiales Find Model Problemas Format currency forward/backward navigation and bookmark in ajax web app From BPM to WebProject - BUILD FAILED Generate and Run button Generation errors on ajax enabled page with many components, ajax links and selective refresh Generation options problem get the attachment files of an email Get Unit problem Get Year from Date Groovy script numer after an error Hacer pruebas unitarias y de integración / Unit Test in WebRatio HelloWorld Unit sample code Help for connect public and private site views Help with math unit. Debug mode says error as result code Hide form until a flow is triggered Hiding landmarks (or flows) when the user is logged in Hierarchy component Hola, qué sistema operativo me recomiendan instalar para ejecutar WebRatio How can i create pagemenu or landmarkmenu with multiple levels. How does WebRatio represent these IFML elements? / ¿Cómo representa WebRatio estos elementos IFML? How i can reuse modules in multiple projects? How to accelerate the generation process? How to avoid language selection automatically according to the browser? How to create a new Web Project How to define the sequence of execution units on a page? how to delete this error? How to disble derby database? How to display the attributes of a related entity. How to filter imported attributes? How to get a wr:AjaxURL tag working How to include Selector Unit result in Mail Unit Body? How to pass vars to a alternative page How to process IFML Model (build with Eclipse editor) with ATL How to Run the Hello World on WebRatio Mobile Edition How to show a page based on a boolean? How to speed up the "last" link using PowerIndexUnit for lots of records How to store data related to an entity in relationships in a project web How to use GoogleGeocoding Add-on i can't install mobile version on windows I can't install Webratio on my Desktop (Ubuntu 13.04 x64) I can't run any application with WebRatio (Table/View 'APP.POST' does not exist) Insert data into database Insert master page to many hybrid modules Installation with java 1.8 Installazione Macosx Integrating a BPM model into an existent WebML model invio mail fallito java.lang.NullPointerException java virtual machine error Job not start correctly JSON I/O Unit e informazioni derivate JSP/DO issues on Tomcat 5.5 (Ubuntu) KO Links in Selector Unit Kubuntu Installation Landmark in hybrid module Link localization Links from Index unit with condition Link Visibility Condition Power Index Unit Linux 32 installation zip Login Error Logs in page MACOS 10.15 CATRALINA can't install Mail multipla maintain the record order in a sortable list mandatory control code parameter is missing Math Unit to update attributes of an entity? Mensaje: the selection cannot be launched and there are no recent launches Missing plugin emulation support error Missing units when importing project [MOBILE] How I extract information from JSON client side? Modifica Entità tramite file xml Multi Entry Unit: How to forward only checked rows? multi-lingual product description Multi Selects didn't work in update page Next Activity Note property - Error synchronizing with web project No access to protected site view with Login No Apache Derby driver found No available activations found No available activations found No database on my cloud account Non riesco a fare funzionare Xml out unit Page Home - First time the Project Web begins Parametrizzazione Selector Unit Problema al generar y ejecutar proyecto Problem accessing MySQL with WebRatio 6 Problema generazione codice Problema Grafo da una lista gerarchica Problema ¨HTTP Status 404" Problemas con el Operations View Delete PROBLEMAS PARA INICIALIZAR WEBRATIO Problem: Compile Failed Problem Example create Unit (no company in employee table) problemi installazione su Mac sistema operativo OSX El Capitan Problem in adding diagrams in IFML Editor (Eclipse) problem on first deploy with webratio Problems to connect Sql Server DB from Webratio Problem syncing reports Problem to run an Application Problem Webratio Personal Edition Activation Problem with application runnung Problem with execution of webratio Problem with ireport Problem with query unit! Problem with Scroller Unit Problem with the deletion of more than 50.000 records in a table Project cannot be opened with WebRatio Community Platform Project generation best practices query a database query unit sql not woking Question about Site Views redeployCheckInterval property Rename passing attributes Replace ID by its value in another table REST connection and Mobile App deploy Retrieve a value and add some value to it Root Context & Enterprise Project Sample web application Schedule a Job when adding a record to the database Search by Selector component does not work Select between parameters Selector unit doesn't return any value in hybrid module Sending mails is not working Sending mails with gmail is not working Setting the Default link for a Switch unit show/hide fields on button click (registration page) Showing items that have a relation with an entity Sincronizar Proyectos en SVN [solved] all links transparent, why ? Solve "Generation Error" with Generate and Run option Some hint before I generate and deploy a webapp on a 64-bit windows system? Something leads to wrong condition expression evaluation. Start Job when WebApp starts Student reserved area, download error sumar atributos de una tabla filtrado por Role Condition Sum entity's values Table 'freeapp43.profesion' doesn't exist Tomcat buttons Tomcat external session store and WebRatio webapp. Transportation Link issue "Unable to close sub-context ..." Unable to compute the controller URL(s) for applicationUnable to compute the controller URL(s) for application having status PROVISIONING Unable to connect to Internet Unable to execute the script java.lang.NullPointerException Unable to find Cloud free function Unable to get ExpenseReport example work in WebRation Personl 7.2.2 Unable to instantiate a new application instance Unable to start WebRation, cannot locate its companion shared library Unable to update the web project Unable to use Visual Debug Unique Fields Unknow property on Dynaclass after generation Unspecified BPM Engine Database Updating attributes of an entity User Login Timestamp Use Running profile en project using relationship role conditional with null Uso de la componente chart de webRatio usuarios y grupos utilizzo componenti database Visibility Condition on Multiple Links From Index Unit Vista de diferentes Site Views webratio 9 for macOS and Linux WebRatio activation problem Webratio Add-ons no permite login Web Ratio Add-ons shop not working Webratio doesn't recognize left-click WebRatio for Linux? WEBRATIO LINUX AT EXECUTION TIME WebRatio Mobile on Linux using wrong network interface. Web Ratio Mobile plateform Macos Sierra Web Ratio Mobile - Remote data mapping problem WebRation - Create Navigation diagram WebRation on OS X Yosemite WebRatio Personal Free Edition activation problem WebRatio Platform 7.2 Community Cloud Edition Webratio with Git support WebRatio y Java 1.8 (o superior) When execute my web application I have this error: returned a null bean where can I download version 7.1.2 personal? Where i can find the old webratio´s versions? Where should I install MAC version? XPCOM Error